[Résolu]Vista:le centre de sécurité ne démarre pas

Ici, vous pouvez demander de l'aide sur Windows Vista. Questions sur les astuces propres à Vista ou problème particulier avec ce système d'exploitation.

Modérateur: Modérateurs

[Résolu]Vista:le centre de sécurité ne démarre pas



Publicité
 

[Résolu]Vista:le centre de sécurité ne démarre pas

Messagepar jami12 » 08 Aoû 2009, 17:38

Bonjour à tous,
c'est la première fois que je pose une question sur un forum, j'ai cherché tout l'après midi, mais je ne pense pas que ce problème ait déjà été abordé.
Voici mon problème: Lorsque je démarre mon PC le centre de sécurité est inactif, et je dois le lancer manuellement, johnny a rencontré le même problème abordé dans le post suivant topic3563.html , mais la solution apportée ne s'applique pas à mon problème.

Je suis conscienceusement ce qui est indiqué dans le post :

•Redémarre ton PC et ne démarre pas le centre de sécurité lorsque ça t'est proposé.
•Clique sur le bouton Démarrer et dans le champ de recherche saisis services.msc puis appuie sur la touche <Entrée>.
La liste des services va s'afficher.
•Double-clique sur le service qui se nomme précisément Centre de sécurité pour en afficher le détail.


Mais lorsque j'arrive à la troisième étape, je ne trouve pas de service nommé "Centre de sécurité".
En fouillant je trouve le service suivant : WSCSVC (Windows Security Center ...) mais il est en "code d'erreur 2", et lorsque je fais un clic droit dessus et que je clique sur "propriétés", j'obtiens le message suivant :"Gestionnaire de configuration: le handle de l'instance du périphérique spécifié ne correspond pas à un périphérique présent"
J'avoue que je suis un peu perdu, et j'espere que quelqu'un pourra m'aider,
d'avance merci.
jami12
Habitué
Habitué
 
Messages: 71
Inscription: 08 Aoû 2009, 17:15

Re: le centre de sécurité ne démarre pas

Messagepar Pierre13 » 08 Aoû 2009, 19:29

Bonjour et bienvenue :hello:

Je vais essayer de t'aider bien que ce ne soit pas vraiment mon domaine...

Le numéro d'erreur de code 2 signifie « Le fichier spécifié est introuvable. »


Va falloir trouver quel est ce fichier...

On va juste faire quelques vérifications.

Ouvre le gestionnaire de services.
Va dans Centre de sécurité.
Clique sur l'onglet dépendances.

Normalement, tu dois trouver:

Appel de procédures distante (RPC) ( nom du service: RpcSs )
Infrastructure de gestion Windows (nom du service: Winmgmt)

Si un des 2 services est absent, clique sur son nom dans la liste principale.

Regarde s'il est activé

Pour Winmgmt (Infrastructure de gestion Windows ) il doit être sur Automatique
Pour RpcSs (Appel de procédures distante) il est aussi sur automatique mais grisé.

Dis-moi s'il y a des différences avec tout ça.

:hello: Pierre
Image
Image
Image
Réparer erreur 2203 Vista, Windows 7, 8 et 8.1
Indisponible la journée en semaine cause travail.
Avatar de l’utilisateur
Pierre13
Modérateur
Modérateur
 
Messages: 3808
Inscription: 11 Mar 2009, 22:29

Re: le centre de sécurité ne démarre pas

Messagepar jami12 » 09 Aoû 2009, 10:16

Merci pour ton aide Pierre,

mais mon problème est là justement, je n'ai pas de "centre de sécurité" dans mon gestionnaire de services, j'ai seulement "WSCSVC" que j'apparente au centre de sécurité, et qui est en code d'erreur 2, je suis sûr maintenant que ca correspond au centre de séurité, puisque la seule action que je peux faire en cliquant dessus c'est "démarrer" ou "arrêter", et lorsque je fais celà je lance ou j'arrete le centre de sécurité, mais c'est tout ce que je peux faire.
Je ne peux pas effectuer la manip que tu me conseilles sur "WSCSVC", si je vais dans les propriétés j'ai le message d'erreur suivant:"Gestionnaire de configuration: le handle de l'instance du périphérique spécifié ne correspond pas à un périphérique présent".

mais je ne desespere, encore merci

jean-michel
jami12
Habitué
Habitué
 
Messages: 71
Inscription: 08 Aoû 2009, 17:15

Re: le centre de sécurité ne démarre pas

Messagepar Pierre13 » 09 Aoû 2009, 10:38

Bonjour

je n'ai pas de "centre de sécurité" dans mon gestionnaire de services,


C'est vrai, jamais mal lu...Toutes mes excuses... :embarrassé:

Une question, est-ce que le pare-feu de Windows fonctionne (activé) ?

:hello: Pierre
Image
Image
Image
Réparer erreur 2203 Vista, Windows 7, 8 et 8.1
Indisponible la journée en semaine cause travail.
Avatar de l’utilisateur
Pierre13
Modérateur
Modérateur
 
Messages: 3808
Inscription: 11 Mar 2009, 22:29

Re: le centre de sécurité ne démarre pas

Messagepar jami12 » 09 Aoû 2009, 10:52

Y a pas de mal ...
oui le pare feu fonctionne mais que si je le lance manuellement, à chaque démarrage...
J'ai eu un probleme de virus la semaine derniere, "win32:trojan-gen", un ami informaticien de passage m'a conseiller d'utiliser combofix, il m'a guidé lors de la manipulation, le virus a disparu, mais crois tu que mon probleme de centre de sécurité pourrait venir de là (de l'utilisation de combofix ou bien du virus)?

jean-michel
jami12
Habitué
Habitué
 
Messages: 71
Inscription: 08 Aoû 2009, 17:15

Re: le centre de sécurité ne démarre pas

Messagepar Pierre13 » 09 Aoû 2009, 11:00

mais crois tu que mon probleme de centre de sécurité pourrait venir de là (de l'utilisation de combofix ou bien du virus)?


C'est bien ma crainte...
On a déjà vu ce genre de problème à cause d'une infection...

Je te conseille de faire une demande de désinfection pour être sûr qu'il n'y a plus rien, sinon on va travailler pour des prunes...

Poster une demande ICI

et cliquer sur Nouveau.

Indiquer ce lien: http://www.vista-xp.fr/forum/topic5300.html pour qu'ils puissent savoir le pourquoi...
ou tu leur fais un résumé...en n'oubliant pas d'expliquer le problème de virus que tu as eu.

:hello: Pierre
Image
Image
Image
Réparer erreur 2203 Vista, Windows 7, 8 et 8.1
Indisponible la journée en semaine cause travail.
Avatar de l’utilisateur
Pierre13
Modérateur
Modérateur
 
Messages: 3808
Inscription: 11 Mar 2009, 22:29

Re: le centre de sécurité ne démarre pas

Messagepar jami12 » 09 Aoû 2009, 11:21

D'accord je vais faire çà.
Si j'ai bien compris, une fois la desinfection effectuée, on reprend contact et on continuera le boulot?
en core merci

jean-michel
jami12
Habitué
Habitué
 
Messages: 71
Inscription: 08 Aoû 2009, 17:15

Re: le centre de sécurité ne démarre pas

Messagepar Pierre13 » 09 Aoû 2009, 11:23

on reprend contact et on continuera le boulot?


Normalement oui, il est possible aussi que Marie prenne le relais parce que demain je serai absent...fin des congés...

:hello: Pierre
Image
Image
Image
Réparer erreur 2203 Vista, Windows 7, 8 et 8.1
Indisponible la journée en semaine cause travail.
Avatar de l’utilisateur
Pierre13
Modérateur
Modérateur
 
Messages: 3808
Inscription: 11 Mar 2009, 22:29

Re: le centre de sécurité ne démarre pas

Messagepar jami12 » 09 Aoû 2009, 11:30

D'accodac, merci , et bonne fin de congés...
jami12
Habitué
Habitué
 
Messages: 71
Inscription: 08 Aoû 2009, 17:15

Re: le centre de sécurité ne démarre pas

Messagepar Marie » 10 Aoû 2009, 13:30

Bonjour :sourire:

Le service pack installé sur ton Vista est le SP1.

Microsoft a mis en ligne, il y a quelques mois, le SP2.

Il est possible (mais pas certain) que l'installation du SP2 recrée le service Centre de sécurité. En tous cas, ça vaut le coup d'essayer. :wink:

Il est étonnant que le SP2 ne t'ait pas été proposé par Windows Update. Les mises à jour automatiques sont bien activées sur ton PC?
Image
Avatar de l’utilisateur
Marie
Administrateur
Administrateur
 
Messages: 21960
Inscription: 22 Juin 2007, 14:56
Localisation: La Valette du Var

Re: le centre de sécurité ne démarre pas

Messagepar jami12 » 10 Aoû 2009, 14:07

RE,
Oui je pense que les mises à jour sont bien activées, puisque il en telecharge très souvent...
Verification faite, je suis réglé sur mises a jour automatiques.
jami12
Habitué
Habitué
 
Messages: 71
Inscription: 08 Aoû 2009, 17:15

Re: le centre de sécurité ne démarre pas

Messagepar jami12 » 10 Aoû 2009, 15:26

Bien,
en regardant dans les mises à jour dispo, j'en ai installé un certain nombre, et on m'a proposé la mise à jour pour le SP2, je viens de l'installer, mais malheureusement, mon probleme de centre de sécurité est toujours là...
jami12
Habitué
Habitué
 
Messages: 71
Inscription: 08 Aoû 2009, 17:15

Re: le centre de sécurité ne démarre pas

Messagepar Marie » 10 Aoû 2009, 20:49

OKI! Donc, il ne nous reste plus que la méthode manuelle.
On y va ... :bric:

D'abord, on va faire l'état des lieux: On va voir si le fichier existe sur ton disque dur puis on va regarder si la clé de registre du service est en bon état.

:arrow: Affiche les fichiers cachés de Vista: Pour afficher les fichiers cachés.


:arrow: Rends toi dans le dossier C:/Windows/System32 (avec l'explorateur Windows) et recherche le fichier wscsvc.dll.
Dis moi si tu le trouves.



:arrow: Ouvre le bloc-notes (Démarrer/Programmes/Accessoires/Bloc-notes) et copie-colle le texte suivant:

reg QUERY "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc" /s > WhatIs.txt
notepad WhatIs.txt


  • Dans le menu Fichier, choisis Enregistrer.
  • Dans le champ Type, choisis Tous les fichiers et appelle le WhatIs.cmd
  • Enregistre-le sur ton bureau.
  • Double-clique sur WhatIs.cmd.
  • Tu vas voir apparaitre sur le bureau un fichier nommé WhatIs.txt et le contenu du fichier WhatIs.txt va s'afficher à l'écran.
    Poste tout son contenu dans ta prochaine réponse. .

Image
Avatar de l’utilisateur
Marie
Administrateur
Administrateur
 
Messages: 21960
Inscription: 22 Juin 2007, 14:56
Localisation: La Valette du Var

Re: le centre de sécurité ne démarre pas

Messagepar jami12 » 10 Aoû 2009, 21:02

Bon alors, j'ai bien trouvé wscsvc.dll a l'emplacement que tu m'avais indiqué.

et voici le contenu de Whatls.txt:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc
DisplayName REG_SZ @C:WINDOWS\System32\wscsvc.dll,-200
ErrorControl REG_DWORD 0x1
ImagePath REG_EXPAND_SZ %SystemRoot%\System32\svchost.exe -k LocalServiceNetworkRestricted
Start REG_DWORD 0x2
Type REG_DWORD 0x20
Description REG_SZ @C:WINDOWS\System32\wscsvc.dll,-201
DependOnService REG_MULTI_SZ RpcSs\0winmgmt
ObjectName REG_SZ NT AUTHORITY\LocalService
ServiceSidType REG_DWORD 0x1
RequiredPrivileges REG_MULTI_SZ SeChangeNotifyPrivilege\0SeImpersonatePrivilege
DelayedAutoStart REG_DWORD 0x1
FailureActions REG_BINARY 805101000000000000000000030000001400000001000000C0D4010001000000E09304000000000000000000

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc\Enum
0 REG_SZ Root\LEGACY_WSCSVC\0000
Count REG_DWORD 0x1
NextInstance REG_DWORD 0x1

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc\Parameters
ServiceDllUnloadOnStop REG_DWORD 0x1
ServiceDll REG_EXPAND_SZ %SYSTEMROOT%\system32\wscsvc.dll

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc\Security
Security REG_BINARY 01001480C8000000D4000000140000003000000002001C000100000002801400FF010F00010100000000000100000000020098000600000000001400FD01020001010000000000051200000000001800FF010F0001020000000000052000000020020000000014009D010200010100000000000504000000000014008D010200010100000000000506000000000014000001000001010000000000050B000000000028001500000001060000000000055000000049599D779156E555DCF4E20EA78BEBCA7B421356010100000000000512000000010100000000000512000000
jami12
Habitué
Habitué
 
Messages: 71
Inscription: 08 Aoû 2009, 17:15

Re: le centre de sécurité ne démarre pas

Messagepar Marie » 10 Aoû 2009, 23:30

:arrow: Tout d'abord, sauvegarde le registre de la façon suivante:

  • Fais Démarrer/Exécuter, saisis regedit puis clique sur OK.

  • Clique sur Ordinateur pour le mettre en surbrillance.

  • Dans le menu Fichier, clique sur Exporter.

  • Donne un nom à la sauvegarde: SaveReg (par exemple) puis clique sur Enregistrer.
    La sauvegarde est enregistrée par défaut dans le répertoire Documents.


:arrow: De retour dans l'éditeur de registre, dans la partie gauche de la fenêtre et en cliquant sur les petits en regard des dossiers, déroule la clé:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc

  • Clique sur wscsvc pour le mettre en surbrillance.

  • Dans la partie droite de la fenêtre, recherche dans la colonne Nom, la valeur qui s'appelle Description.

  • Double-clique sur Description et dans Données de la valeur, remplace ce qui existe en copiant-collant ce qui est dans le cadre ci-dessous:

    @%SystemRoot%\System32\wscsvc.dll,-201

  • Clique sur OK pour enregistrer la modification.
  • Toujours dans la partie droite de la fenêtre, recherche ensuite la valeur qui s'appelle DisplayName
  • Double-clique sur DisplayName et dans Données de la valeur, remplace ce qui existe en copiant-collant ce qui est dans le cadre ci-dessous:

    @%SystemRoot%\System32\wscsvc.dll,-200

  • Clique sur OK pour enregistrer la modification.
  • Au final, tu dois obtenir exactement ceci:

    Image

  • Sors du registre par la croix en haut, à droite de la fenêtre.

  • Redémarre le PC et donne moi des nouvelles du centre de sécurité.

Image
Avatar de l’utilisateur
Marie
Administrateur
Administrateur
 
Messages: 21960
Inscription: 22 Juin 2007, 14:56
Localisation: La Valette du Var

Suivante

Retourner vers Aide à la résolution de problèmes sur Windows Vista

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités